C Program to check whether ith bit in a number N is set or not
Get a number n and bit I, check whether ith bit in num is set or not.
Sample Input 1:
8 3
Sample Output 1:
Not Set
Sample Input 2:
8 1
Sample Output 2:
Set Explanation:
0000 1000
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num,bit;
printf("Enter a number and a bit:");
scanf("%d %d",&num,&bit);
num=num>>(bit-1);
if((num&1)!=0)
{
printf("%d is set",bit);
}
else
{
printf("%d is reset",bit);
}
return 0;
}
Program Explanation
left shift the number num by n-1 times move the nth bit to LSB.
Do AND operation between num and 1, if the LSB is 1 then output is 1, if LSB is 0 then output is 0.
Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon