C Program to find whether the given number is odd or even number
Get a number num and check whether num is odd or even?
Sample Input 1:
45
Sample Output 1:
ODD
Sample Input 2:
56
Sample Output 2:
EVEN
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int num;
printf("Enter two numbers:");
scanf("%d"&num);
if(num%2==0)
{
printf("%d is even",num);
}
else
{
printf("%d is odd",num);
}
return 0;
}
Program Explanation
Get input num from user using scanf statement
check whether the remainder of num divided by 2 is equal to 0 using if statement.
if it is 0, then print num is even using printf statement.
Else print num is odd using printf statement.
Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon