C Program to find whether the given year is leap year or not
Get a year and check whether year is leap year or not.
sample Input 1:
2016
Sample Output 1:
Leap year
Sample Input 2:
2017
Sample Output 2:
Not Leap Year
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include<stdio.h>
int main()
{
int year;
printf("Enter a year:");
scanf("%d"&year);
if(year%4==0)
{
printf("%d is leap year",year);
}
else
{
printf("%d is not leap year",year);
}
return 0;
}
Program Explanation
Get input year from user using scanf statement
check whether the remainder of year divided by 4 is equal to 0 using if statement.
if it is 0, then print year is leap year using printf statement.
Else print year is not leap year using printf statement.
Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to calculate different discount for different Bill amount
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon