C Program to calculate different discount for different Bill amount
Get price and quantity of a product, calculate bill amount, calculate 10% discount for the bill amount 5000 and above, 5% discount for the bill amount 1000 and above.
Sample Input 1:
10 400
Sample Output 1:
3800
Sample Input 2:
10 500
Sample Output 2:
4500
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
#include<stdio.h>
int main()
{
//write your code here
}
Program or Solution
#include <stdio.h>
int main(void)
{
double quantity,price,amount,discount;
printf("Enter quantity and price:");
scanf("%lf %lf",&quantity, &price);
amount=quantity*price;
if(amount>5000)
{
discount=amount*0.10;
}
else if(amount > 1000)
{
discount=amount*0.05;
}
else
{
discount=0;
}
amount = amount - discount;
printf("%lf",amount);
return 0;
}
Program Explanation
chained conditional check is used here to check whether amount is greater than 1000 or greater than 5000.
any one of the expression to calculate discount will be executed.
Comments
Related Programs
- C Program to calculate discount for purchase above 5000
- C Program to find greatest among two numbers
- C Program to find smallest among two numbers
- C Program to find whether the given number is odd or even number
- C Program to find whether the difference between two numbers is even or odd
- C Program to find whether the given number is 3 digit number or not
- C Program to find greatest among three numbers
- C Program to find smallest among three numbers
- C Program to find whether the given number is divisible by 3
- C Program to find whether the given year is leap year or not
- C Program to find whether the last digit of given number is divisible by 3
- C Program to Arithmetic Calculator using switch case Statements
- C Program to grade calculation system
- C Program to find the whether the last digit of given two numbers are equal or not
- C Program to check whether ith bit in a number N is set or not
- C Program to check odd or even using bitwise operator
coming Soon
coming Soon