Java Program to Swap two numbers using third variable
Get two integers a and b from user and swap the values
Sample Input 1:
6 5
Sample Output 1:
5 6
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class SwapT
{
public static void main(String args[])
{
int input1,input2,temp;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Input 1:");
input1=sc.nextInt();
System.out.println("Enter The Input 2:");
input2=sc.nextInt();
temp=input1;
input1=input2;
input2=temp;
System.out.println("Now The Inputs After Swapping is:");
System.out.println("The Output is:");
System.out.println("The Input 1 is:"+input1);
System.out.println("The Input 2 is:"+input2);
}
}
Program Explanation
Get input1 and input2 using scanner class. swap the values using third variable temp. Print input1 and input2 using system.out.println()Comments
Related Programs
- Java Program to Addition of two numbers
- Java Program to subtraction of two numbers
- Java Program to multiply two numbers
- Java Program to divide two numbers
- Java Program to find modulus of two numbers
- Java Program to Kilo Meters to Meters
- Java Program to Meters to Kilo Meters
- Java Program to find area of Square
- Java Program to find area of Rectangle
- Java Program to find area of Right-angled triangle
- Java Program to find area of triangle
- Java Program to find area of Circle (Use Constant)
- Java Program to find the distance between two points in 2D space
- Java Program to calculate kilobytes to bytes
- Java Program to calculate bytes to kilobytes
- Java Program to find simple interest
- Java Program to calculate Fahrenheit to Celsius
- Java Program to calculate Celsius to Fahrenheit
- Java Program to Swap of two numbers without using third variable
- Java Program to print the last digit of given number N
- Java Program to Calculate Salary for Employees
- Post Increment Operator Example in Java
- Pre Increment Operator Example in Java
- Pre Increment and Post Increment Difference in java with Example
- Ternary Operator Example in Java
- Relational Operators Example in java
- Logical Operators Example in Java
coming Soon
coming Soon