Java Program to print the last digit of given number N
Get an number n from user and display the last digit of n
Sample Input 1:
623
Sample Output 1:
3
Sample Input 2:
280
Sample Output 2:
0
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class LastD
{
public static void main(String args[])
{
int input1,digit;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Input:");
input1=sc.nextInt();
digit=input1%10;
System.out.println("The Last Digit is:"+digit);
}
}
Program Explanation
Get a input input1 (using scanner class) Seprate the last digit of number num by "digit = input%10".
(% by 10 always gives last digit of a number) print the digit (using system.out.println)
Comments
Related Programs
- Java Program to Addition of two numbers
- Java Program to subtraction of two numbers
- Java Program to multiply two numbers
- Java Program to divide two numbers
- Java Program to find modulus of two numbers
- Java Program to Kilo Meters to Meters
- Java Program to Meters to Kilo Meters
- Java Program to find area of Square
- Java Program to find area of Rectangle
- Java Program to find area of Right-angled triangle
- Java Program to find area of triangle
- Java Program to find area of Circle (Use Constant)
- Java Program to find the distance between two points in 2D space
- Java Program to calculate kilobytes to bytes
- Java Program to calculate bytes to kilobytes
- Java Program to find simple interest
- Java Program to calculate Fahrenheit to Celsius
- Java Program to calculate Celsius to Fahrenheit
- Java Program to Swap two numbers using third variable
- Java Program to Swap of two numbers without using third variable
- Java Program to Calculate Salary for Employees
- Post Increment Operator Example in Java
- Pre Increment Operator Example in Java
- Pre Increment and Post Increment Difference in java with Example
- Ternary Operator Example in Java
- Relational Operators Example in java
- Logical Operators Example in Java
coming Soon
coming Soon