Java Program to calculate bytes to kilobytes
Get bytes b from user and find kilobytes kb
Sample Input 1:
2048
Sample Output 1:
2
Sample Input 2:
1024
Sample Output 2:
1
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class Converter
{
public static void main(String args[])
{
Double kilobytes,bytes;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Bytes:");
bytes=sc.nextDouble();
kilobytes=bytes/1024;
System.out.println("The KiloBytes Is:"+kilobytes);
}
}
Program Explanation
Get bytes Byt as input (using scanner class) Calculate kilobytes Kilo by dividing bytes Byt by 1024. (kb=b/1024, 1024 bytes is equal to 1 kilobyte) Print kilobytes kb (using System.out.println)Comments
Related Programs
- Java Program to Addition of two numbers
- Java Program to subtraction of two numbers
- Java Program to multiply two numbers
- Java Program to divide two numbers
- Java Program to find modulus of two numbers
- Java Program to Kilo Meters to Meters
- Java Program to Meters to Kilo Meters
- Java Program to find area of Square
- Java Program to find area of Rectangle
- Java Program to find area of Right-angled triangle
- Java Program to find area of triangle
- Java Program to find area of Circle (Use Constant)
- Java Program to find the distance between two points in 2D space
- Java Program to calculate kilobytes to bytes
- Java Program to find simple interest
- Java Program to calculate Fahrenheit to Celsius
- Java Program to calculate Celsius to Fahrenheit
- Java Program to Swap two numbers using third variable
- Java Program to Swap of two numbers without using third variable
- Java Program to print the last digit of given number N
- Java Program to Calculate Salary for Employees
- Post Increment Operator Example in Java
- Pre Increment Operator Example in Java
- Pre Increment and Post Increment Difference in java with Example
- Ternary Operator Example in Java
- Relational Operators Example in java
- Logical Operators Example in Java
coming Soon
coming Soon