Java Program to calculate Fahrenheit to Celsius
Sample Input 1:
Enter the Fahrenheit: 284
Sample Output 1:
The Celsius Is :140
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
class Converter
{
public static void main(String args[])
{
double fahreheit,celsius;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Fahrenheit:");
fahreheit=sc.nextDouble();
celsius=(fahreheit-32)*0.5556;
System.out.println("The Celsius Is:"+celsius);
}
}
Program Explanation
Get Fahrenheit as input (using scanner class) Calculate Celsius using Formula celsius=(fahreheit-32)*0.5556 print Celcius (using system.out.println).Comments
Related Programs
- Java Program to Addition of two numbers
- Java Program to subtraction of two numbers
- Java Program to multiply two numbers
- Java Program to divide two numbers
- Java Program to find modulus of two numbers
- Java Program to Kilo Meters to Meters
- Java Program to Meters to Kilo Meters
- Java Program to find area of Square
- Java Program to find area of Rectangle
- Java Program to find area of Right-angled triangle
- Java Program to find area of triangle
- Java Program to find area of Circle (Use Constant)
- Java Program to find the distance between two points in 2D space
- Java Program to calculate kilobytes to bytes
- Java Program to calculate bytes to kilobytes
- Java Program to find simple interest
- Java Program to calculate Celsius to Fahrenheit
- Java Program to Swap two numbers using third variable
- Java Program to Swap of two numbers without using third variable
- Java Program to print the last digit of given number N
- Java Program to Calculate Salary for Employees
- Post Increment Operator Example in Java
- Pre Increment Operator Example in Java
- Pre Increment and Post Increment Difference in java with Example
- Ternary Operator Example in Java
- Relational Operators Example in java
- Logical Operators Example in Java
coming Soon
coming Soon