Java Program to find simple interest
Sample Input 1:
Enter the number of years: 1 Enter the Rate: 10 Enter the Principle Amount: 1000
Sample Output 1:
100
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
Program or Solution
import java.util.*;
class SimpleInt
{
public static void main(String args[])
{
int n,p;
double rate,si;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Number Of Months:");
n=sc.nextInt();
System.out.println("Enter The Rate:");
rate=sc.nextDouble();
System.out.println("Enter The Principle Amount:");
p=sc.nextInt();
si=(p*rate*n)/100;
System.out.println("The Simple Interest Is:"+si);
}
}
Program Explanation
Get principal p, number of months n and rate of interest rate as inputs.
(using scanner class) calculate Simple Interest Si by formula Si= p*n*rate/100 print Simple Interest Si using system.out.println.
Comments
Related Programs
- Java Program to Addition of two numbers
- Java Program to subtraction of two numbers
- Java Program to multiply two numbers
- Java Program to divide two numbers
- Java Program to find modulus of two numbers
- Java Program to Kilo Meters to Meters
- Java Program to Meters to Kilo Meters
- Java Program to find area of Square
- Java Program to find area of Rectangle
- Java Program to find area of Right-angled triangle
- Java Program to find area of triangle
- Java Program to find area of Circle (Use Constant)
- Java Program to find the distance between two points in 2D space
- Java Program to calculate kilobytes to bytes
- Java Program to calculate bytes to kilobytes
- Java Program to calculate Fahrenheit to Celsius
- Java Program to calculate Celsius to Fahrenheit
- Java Program to Swap two numbers using third variable
- Java Program to Swap of two numbers without using third variable
- Java Program to print the last digit of given number N
- Java Program to Calculate Salary for Employees
- Post Increment Operator Example in Java
- Pre Increment Operator Example in Java
- Pre Increment and Post Increment Difference in java with Example
- Ternary Operator Example in Java
- Relational Operators Example in java
- Logical Operators Example in Java