Java Program to find the distance between two points in 2D space
Get x and y coordinates of two points(x1,y1,x2,y2) and find distance between two points
Sample Input 1:
3 4 4 5
Sample Output 1:
1.414
Flow Chart Design
Try your Solution
Strongly recommended to Solve it on your own, Don't directly go to the solution given below.
public class Hello
{
public static void main(String args[])
{
//Write your code here
}
}
Program or Solution
import java.util.*;
import java.lang.Math.*;
class Distance
{
public static void main(String args[])
{
int x1,x2,y1,y2;
int x,y;
double distance;
Scanner sc=new Scanner(System.in);
System.out.println("Enter The Coordinates:");
x1=sc.nextInt();
x2=sc.nextInt();
y1=sc.nextInt();
y2=sc.nextInt();
x=x2-x1;
y=y2-y1;
distance=Math.sqrt((x*x)+(y*y));
System.out.println("The Distance Is:"+distance );
}
}
Program Explanation
Get x1,y1,x2 and y2 coordinates of two points(using scanner class) Calculate distance by the eculdian distance formula. Math.sqrt is function available in java library to find square root. Print distance (using system.out.println).Comments
Related Programs
- Java Program to Addition of two numbers
- Java Program to subtraction of two numbers
- Java Program to multiply two numbers
- Java Program to divide two numbers
- Java Program to find modulus of two numbers
- Java Program to Kilo Meters to Meters
- Java Program to Meters to Kilo Meters
- Java Program to find area of Square
- Java Program to find area of Rectangle
- Java Program to find area of Right-angled triangle
- Java Program to find area of triangle
- Java Program to find area of Circle (Use Constant)
- Java Program to calculate kilobytes to bytes
- Java Program to calculate bytes to kilobytes
- Java Program to find simple interest
- Java Program to calculate Fahrenheit to Celsius
- Java Program to calculate Celsius to Fahrenheit
- Java Program to Swap two numbers using third variable
- Java Program to Swap of two numbers without using third variable
- Java Program to print the last digit of given number N
- Java Program to Calculate Salary for Employees
- Post Increment Operator Example in Java
- Pre Increment Operator Example in Java
- Pre Increment and Post Increment Difference in java with Example
- Ternary Operator Example in Java
- Relational Operators Example in java
- Logical Operators Example in Java
coming Soon
coming Soon